Question streaming audio agité


Je pourrais utiliser un peu d'aide pour résoudre les problèmes de streaming audio. Le problème est la lecture saccadée indépendamment de l'audio ou de la vidéo avec l'audio. Chromium et Firefox ont tous deux le problème, mais les fichiers joués directement sur la machine avec Rhythmbox sonnent très bien.

J'utilise 12.04 LTS sur un C2D T9300.

La plupart des problèmes audio que d'autres interrogent semblent être liés au matériel. Les informations suivantes peuvent donc être pertinentes.

  sudo lshw -c multimedia
   *-multimedia     
   description: Audio device
   product: 82801H (ICH8 Family) HD Audio Controller
   vendor: Intel Corporation
   physical id: 1b
   bus info: pci@0000:00:1b.0
   version: 03
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list
   configuration: driver=snd_hda_intel latency=0
   resources: irq:48 memory:f8400000-f8403fff

2
2017-09-09 13:54


origine




Réponses:


Votre problème ressemble plus à un problème de bande passante. Si le flux audio provient d'une diffusion externe, vous êtes limité à la fois par votre bande passante et par la bande passante du diffuseur.

Cela se produit généralement lorsque vous essayez de rassembler une diffusion à haut débit. Avez-vous testé le comportement de votre système audio lors de la collecte d'informations à un autre endroit?

La mise en mémoire tampon doit également être considérée, malheureusement la mise en mémoire tampon elle-même ne peut pas être contrôlée par logiciel si le cas est comme une station de radio Internet et dans certains cas, vous pouvez autoriser la mise en mémoire tampon à "Problèmes de mise en mémoire tampon et de lecture"

Est-ce que cela vous dérange de fournir des informations supplémentaires sur le flux à l'origine de votre problème pour pouvoir effectuer un test? après quoi cette réponse peut être modifiée pour inclure les résultats du test.

Bonne chance!


3
2017-09-09 14:09





J'ai eu ce problème exact, essayez ceci, quand votre vidéo en continu passe aux paramètres du système (la vitesse avec la clé / tournevis dessus) cliquez sur l'onglet le plus à droite ("simultanée sortie ") et activez la case à cocher (il convient de vérifier à la fin), bien sûr, il s’agit d’un correctif temporaire. Pour une raison quelconque, le logiciel ne reconnaît pas cette case en cours de vérification. (demandez à un développeur pourquoi) mais après cela, le son / vidéo a été diffusé parfaitement.


1
2017-11-27 04:35