Question Automount de disque dur externe


J'ai une station de mémoire Intenso 6002560 1TB - un disque dur externe. Ce disque dur est connecté via un câble Y-USB. Lorsque je connecte les deux extrémités USB à mon ordinateur portable, mon système Ubuntu 10.04.4 LTS le reconnaît:

moose@pc07:~$ lsusb
[...]
Bus 002 Device 005: ID 13fd:1840 Initio Corporation 
[...]

et

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00065e10

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       37810   303704064   83  Linux
/dev/sda2           37810       38914     8864769    5  Extended
/dev/sda5           37810       38914     8864768   82  Linux swap / Solaris

Disk /dev/sdc: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0d6ea32a

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1      121601   976759008+   c  W95 FAT32 (LBA)

Mais il n'a pas été monté:

moose@pc07:/dev$ mount -l
/dev/sda1 on / type ext4 (rw,errors=remount-ro,user_xattr)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/moose/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=moose)

Cependant, je pourrais le monter manuellement avec

mount -t vfat /dev/sdc1 /mnt/sdc1

comme vous pouvez le voir ici:

moose@pc07:~$ mount -l
/dev/sda1 on / type ext4 (rw,errors=remount-ro,user_xattr)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/moose/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=moose)
/dev/sdc1 on /mnt/sdc1 type vfat (rw)

edit: Une autre commande:

moose@pc07:~$ sudo blkid -o list
device                     fs_type    label       mount point                    UUID
----------------------------------------------------------------------------------------------------------------------
/dev/sda1                  ext4                   /                              45eb611b-517e-425b-8057-0391726cccd5
/dev/sda5                  swap                   <swap>                         e9dc42f3-594c-4b62-874a-305eda5eed41
moose@pc07:~$ blkid -o list
device                     fs_type    label       mount point                    UUID
----------------------------------------------------------------------------------------------------------------------
/dev/sda1                  ext4                   /                              45eb611b-517e-425b-8057-0391726cccd5
/dev/sda5                  swap                   <swap>                         e9dc42f3-594c-4b62-874a-305eda5eed41
/dev/sdc1                                         /mnt/sdc1                      

edit: une autre commande:

moose@pc07:~$ ls -l /dev/disk/by-uuid/
total 0
lrwxrwxrwx 1 root root 10 2012-09-30 09:31 45eb611b-517e-425b-8057-0391726cccd5 -> ../../sda1
lrwxrwxrwx 1 root root 10 2012-09-30 09:31 e9dc42f3-594c-4b62-874a-305eda5eed41 -> ../../sda5

Voici un lien vers un Question de Launchpad à propos de ce problème.

Mais je voudrais qu'il se monte automatiquement. Qu'est-ce que je dois faire?


2
2017-09-29 11:35


origine


salut, c'est étrange, le résultat que vous montrez est comme s'il n'était pas monté. Si vous essayez ls -l / dev / disk / by-uuid / pour que vous puissiez tous les lister autrement, quelle est la sortie? - bob
@ user81022: il ne sort que les deux partitions de mon disque dur interne, voir l'article édité. - Martin Thoma
Je pense que puisque le lecteur est fat32, vous devriez le monter en tant que type sdb (pas sdc). Donc, d'abord sudo umount / dev / sdc1 et ensuite le remonter (/ dev / sdb1). J'aimerais pouvoir aider davantage. - bob
/dev/sdb1 n'existe pas (mount: special device /dev/sdb1 does not exist ). Si j'essaye de monter /dev/sdb ça dit mount: no medium found on /dev/sdb. Au fait, chkdisk sur une machine Windows n'a révélé aucune erreur. Il a fonctionné sur Windows hors de la boîte. - Martin Thoma


Réponses:


C'est une vieille question mais j'ai pensé que cela pourrait encore aider quelqu'un.

J'ai eu le même problème avec ce disque dur. La source s'est avérée être le format initial de la partition. Reformatage en NTFS en utilisant le Disques (gnome-disks) outil fait se comporter comme tout autre disque dur USB.


2
2018-06-03 16:58



Cela a fait l'affaire! Merci beaucoup! Savez-vous s'il existe un outil MATE avec lequel cela peut être fait? - Martin Thoma
Impressionnant! Vous ne savez pas ce que vous entendez par "outil MATE" - en tout cas, si gnome-disks n'est pas disponible, mkfs.ntfs devrait également faire l'affaire sur la plupart des systèmes. - user2361830


Ici vous avez un bon guide sur la façon de monter des disques.

https://help.ubuntu.com/community/AutomaticallyMountPartitions

Vous devez ajouter votre lecteur au fichier / etc / fstab qui contrôle les périphériques montés, avec des paramètres tels que

  • l'entraînement de montage,
  • le point de montage
  • système de fichiers utilisé
  • et plusieurs autres options

bonne chance!

MODIFIER: Si vous modifiez manuellement fstab au lieu d'utiliser une interface, faites attention aux lignes que vous modifiez. Effectuez d'abord une sauvegarde du fichier ou vous risquez de ne pas démarrer correctement votre système.


1
2017-09-29 12:34





Comme il est monté, lancez sudo blkid pour voir l'UUID du volume. Ensuite, dans / etc / fstab, ajoutez:

UUID = xxx / media / xxx vfat 0 0


0
2017-09-29 12:05



il semble ne pas avoir d'UUID (voir mon édition). Qu'est-ce que je fais maintenant? (et pourquoi le périphérique n’est-il pas affiché lorsque je cours blkid avec sudo?) - Martin Thoma