Question Pourquoi toutes les vidéos sont-elles saccadées sur un contrôleur graphique Intel 845G en 12.04?


Actuellement, j'utilise le bureau Lubuntu 12.04 installé sur mon PC. Lorsque je lis des vidéos, les vidéos sont vraiment lentes. Il saute des cadres

J'ai des périphériques PCI suivants installés sur le système Pont hôte: Intel Corporation 82845G / GL [Contrôleur DRAM / interface hôte-concentrateur / GE / PE / Brookdale-G] (rev 03)

Contrôleur compatible VGA: Intel Corporation 82845G / GL [Périphérique graphique intégré au chipset Brookdale-G] / GE (version 03) (prog-if 00 [contrôleur VGA])

Les packages xserver-xorg-video-intel et mesa-utils sont installés. Le rendu direct est activé. Peu importe si elle est activée ou non, les deux fois, les vidéos sont lentes presque de la même façon. En cherchant une solution, j'ai trouvé une page sur les pilotes d'Intel http://manpages.ubuntu.com/manpages/precise/man4/intel.4.html qui traite des pilotes graphiques Intel.

Y at-il un moyen de changer le VideoRam à une valeur plus élevée peut être utile? Actuellement, la mémoire AGP est de 128 Mo et à partir de la page de manuel ci-dessus, VideoRam sera défini sur 8 Mo si AGP> = 128 Mo. 82845G a une mémoire AGP de 128 Mo. Y at-il de toute façon je peux augmenter VideoRam? J'ai essayé Ubuntu avec AGP Memory 256 Mo, où videoRam sera réglé à 24 Mo par défaut, les vidéos HD jouent également en douceur même si le processeur est Intel Celron 1.6Ghz.

Y a-t-il quelque chose que je puisse faire pour augmenter la taille de la vidéaste? ou est-ce à cause d'autre chose?

Un commentateur m'a demandé de joindre des sorties de dmesg, lsmod, lshw et /var/log/kern.log. 
Voici la sortie de ces commandes http://paste.ubuntu.com/1071664/


2
2017-07-02 16:22


origine


N'y a-t-il pas une option dans votre BIOS pour augmenter la RAM partagée? ou tu as déjà essayé ça? - Uri Herrera
@ UriHerrera, Oui, j'ai augmenté ma mémoire RAM partagée dans le BIOS à 128 Mo, ce qui correspond à un nombre maximal de chipsets 82845G, mais je ne change pas même si je l'ai augmenté ou réduit à 64 Mo - Mahesh Bhat


Réponses:


Notez que le VideoRam le réglage que vous mentionnez est seulement nécessaire / honoré pour le chipsets i810 / 815; pour les plus récents, y compris votre i845G, la page de manuel dit:

For the 830M and later, the driver will automatically size  its  memory
allocation  according  to the features it will support.  Therefore, the
VideoRam option, which in the past had been  necessary  to  allow  more
than some small amount of memory to be allocated, is now ignored.

Y a-t-il quelque chose que je puisse faire pour augmenter la taille de la vidéaste?

Oui toi devrait être capable d'augmenter la taille d'ouverture AGP ("mémoire graphique") dans votre BIOS (au démarrage de l'ordinateur) de 128 Mo à une taille supérieure. D'après mon expérience, cela facilite souvent la lecture de vidéos sur ces vieux systèmes graphiques intégrés.


3
2017-07-02 16:53



Dans la même page de manuel juste au-dessus des lignes que vous avez citées, ces lignes existent aussi "code". Pour le 830M et les versions ultérieures, cela est nécessaire pour que le pilote utilise plus de RAM vidéo que le BIOS . Ceci est généralement réalisé avec un pilote de noyau "agpgart" ou "agp". Linux, FreeBSD, OpenBSD, NetBSD et Solaris disposent de tels pilotes de noyau. - Mahesh Bhat
Bon, mais c'est un module du noyau, pas un noyau ou un module paramètre. Veuillez partager le contenu ou la sortie des commandes / fichiers suivants pour mieux nous aider à résoudre votre problème (instructions dans cette réponse): des dossiers): /var/log/kern.log, commande (s): dmesg, lsmod, sudo lshw - ish
voici le résultat des commandes que vous avez mentionnées paste.ubuntu.com/1071664 - Mahesh Bhat