Question Comment puis-je réparer les polices, pas le rendu et les lettres manquantes?


J'ai une nouvelle installation d'Ubuntu 14.10 sur mon ordinateur portable. Il semble qu'il manque des lettres dans les fichiers et les dossiers, ainsi que dans les menus et les fenêtres de configuration. Je ne sais pas par où commencer pour résoudre ce problème.

enter image description here enter image description here


98
2018-02-13 02:46


origine


J'ai exactement le même problème sur un DELL E7450 censé supporter officiellement Ubuntu. En cours d'exécution 14.04.2 LTS former un USB en direct dès maintenant. - Dan Dascalescu
Voir cette réponse: askubuntu.com/a/606583/395351 . Semble être un bug confirmé pour les cartes Intel HD5500. - rob
J'ai le même problème avec Lenovo X250. cela rend inutile Ubuntu - elhadi
J'ai parfois le même problème avec Lenovo G50-80. Après un redémarrage, cela résout généralement (jusqu'à la prochaine fois). - jutky
Je ne peux pas croire que ce problème se produit encore en 16.04. Quand Ubuntu va-t-il corriger ce bug? - Claudiu Creanga


Réponses:


J'ai eu le même problème sur mon Dell Inspiron avec i5 de 5ème génération sous Ubuntu 14.04. Heureusement, j'ai trouvé une solution facile pour cela. Tout d'abord, installez Ubuntu Tweak (les commandes suivantes fonctionnent pour l'installer):

sudo add-apt-repository ppa:tualatrix/ppa 
sudo apt-get update
sudo apt-get install ubuntu-tweak

Ensuite, allez à Fonts, changez Antialiasing option de Subpixels Antialiasing (LCD screens only) à Standard Grayscale Aliasing et tout semble fonctionner correctement. En fait, le problème apparaît / disparaît immédiatement lors de la modification du réglage, il semble donc que ce soit effectivement la cause possible.

Guide graphique - Outil Ubuntu Tweak

Avec des lettres manquantes, vous pourriez avoir du mal à trouver le libellé "Antialiasing" etc. Voici un guide graphique sur la façon dont l’outil ressemble aux polices de travail, pour vous aider à trouver où cliquer.

Dans la première fenêtre, vous devez sélectionner l'onglet "Tweaks" dans la rangée supérieure (troisième à gauche - c'est-à-dire la centrale), puis "Fonts" (première icône à gauche dans la première ligne):

Ubuntu Tweak -> Tweaks -> Fonts

Ensuite, cliquez sur la barre de choix inférieure et choisissez la option du milieu (Je ne peux pas montrer une capture d'écran avec la barre de choix ouverte, malheureusement, Ubuntu ne semble pas réagir à moi en appuyant sur la touche PrtScr puis sur: - /)

Antialiasing choice bar

Guide graphique - Outil Unity Tweak

Guide similaire à celui ci-dessus, mais pour le Unité Tweak outil.

Après avoir lancé l'outil, cliquez sur "Polices" (icône la plus à droite dans la troisième ligne):

Unity Tweak -> Fonts

Cliquez ensuite sur la barre de choix marquée et sélectionnez le milieu option quand il s'ouvre:

Fonts -> Appearance -> Antialiasing


50
2018-06-07 16:12



Cela peut également être fait via le gnome-tweak-tool pour ceux qui utilisent l'environnement de bureau GNOME (ou wm + gnome-settings-deamon, comme moi) - user898763452
Sur Ubuntu 16.04, et probablement plus tôt, il s'agit de - djvs
Il semble que ce ne soit qu'une solution temporaire pour moi (après que les prochaines suspendent les lettres disparaissent à nouveau) - groovy354
Peut-être que je manque quelque chose, mais je ne peux pas trouver un moyen de le faire à travers le gnome-tweak-tool. Quelqu'un pourrait-il me donner un coup de main?
J'ai dû augmenter mon test scaling factor de 1,00 à 1,10 pour que le correctif unitu-tweak-tool fonctionne réellement partout - emmagras


Pour moi, cela se produit généralement (plus tôt) quand un deuxième écran est connecté à l'ordinateur portable. Changer l'aliasing en utilisant tweak Ubuntu ne résout que temporairement le problème. Même chose pour changer la taille de la police en utilisant les écrans d'ubuntu.

L'installation d'Intel Graphics Installer pour Linux (qui est maintenant à la version 1.1.0) ne semble rien faire du tout. J'ai exécuté l'installateur via le centre de logiciels sans aucun problème.

J'ai utilisé ceci solution de contournement pour une journée maintenant sans aucun problème. Sur Ubuntu 14.04:

Créez ou éditez /etc/X11/xorg.conf Ajoutez le code ci-dessous, enregistrez et redémarrez

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"  "uxa"
EndSection

11
2018-06-25 13:12



Toujours le 15.04 - tutuca
Cela m'a aidé pendant un certain temps, mais après un certain temps, le problème est revenu. - jutky
@tutuca, ça se passait le 15.04 pour moi aussi, jusqu’à ce que je mette à jour mon noyau 3.19.0-29-generic. Maintenant, ce n'est pas arrivé du tout. - user898763452
Je tripote un peu mes configurations de polices et elles ont été corrigées. - tutuca
Notez que AccelMethod UXA est le précédent et le plus lent. - vorburger


Cela pourrait être un problème de pilote. Si vous utilisez un processeur graphique Intel, essayez d'installer la dernière version (1.0.8) Intel Graphics Installer pour Linux, qui supporte 14.10. J'ai eu le même problème avec mon ordinateur portable i5 de 5ème génération mais il a résolu ce problème.


5
2018-03-23 06:09



L'installateur dépend d'un paquet impair, ttf-ancient-fonts et Software Center ne l’installe pas automatiquement. - Dan Dascalescu
L'installateur aussi ne fonctionne pas sur Ubuntu 14.04. - Dan Dascalescu
Notez qu'à ce jour, le programme Intel Graphics Installer pour Linux 1.4.0 [1] "est destiné à Ubuntu 15.10 ou Fedora 23. Ubuntu 16.04 est déjà à jour avec la dernière pile Intel Graphics du premier trimestre 2016 et aucun installateur graphique n'est donc nécessaire." [1] 01.org/linuxgraphics/downloads/… - vorburger


J'ai eu le même problème sur mon nouvel ordinateur portable Dell avec Intel HD Graphics 5500 (Broadwell GT2). Si vous aviez un problème de dépendance lors de l'installation de ce qui précède Installateur graphique pour Linux, vous pouvez installer Installer le paquet GDebi qui peut facilement résoudre les problèmes de dépendance.

Ou première installation GDebi 

sudo apt-get install gdebi

Téléchargez le pilote 64 bits pour un système X64 ou la version 32 bits pour un X86.

wget https://download.01.org/gfx/ubuntu/14.10/main/pool/main/i/intel-linux-graphics-installer/intel-linux-graphics-installer_1.0.8-0intel1_amd64.deb

Enfin, utilisez GDebi pour installer ce pilote

sudo gdebi intel-linux-graphics-installer_1.0.8-0intel1_amd64.deb 

5
2018-05-14 02:26



Vous n'avez pas besoin de GDebi pour installer les fichiers deb. Le Centre de logiciels le fait très bien. Double-cliquez sur le fichier deb ou exécutez-le software-centre intel-linux-graphics-installer_1.0.8-0intel1_amd64.deb. - muru
Je ne sais pas si le Software Center peut résoudre automatiquement les problèmes de dépendance. Je suis un nouvel utilisateur de Linux. :) Merci pour les commentaires! - user304461
Ce lien est cassé, recommande de lier directement à 01.org/linuxgraphics/downloads - Einar Ólafsson
sudo dpkg -i intel-linux-graphics-installer_1.0.8-0intel1_amd64.deb puis sudo apt-get install -f  travaillera aussi - user898763452
le centre logiciel est super lent comparé à gdebi - answerSeeker


J'ai eu le même problème et j'ai trouvé un article suggérant de changer la taille de la police par défaut de "ubuntu" (il fallait installer quelque chose appelé "tweaks" pour pouvoir le faire). Après avoir modifié la taille de la police, tout était affiché correctement.

J'ai toujours des problèmes avec mon terminal qui se masquent de temps en temps, mais il suffit d'appuyer sur Entrée à plusieurs reprises, et tout réapparaît. Très probablement une sorte de bogue de pilote graphique, mais au moins la modification de la taille de la police a résolu la plupart du problème pour moi


1
2018-03-08 11:22





On dirait que le problème était corrigé dans Ubuntu 15.04. J'ai mis à jour et le problème n'est plus un problème.

Au cours de la mise à niveau, j'ai remarqué que plusieurs packages spécifiques à AMD ont été installés.


-1
2018-04-25 17:43



Toujours à 15h04 - tutuca
Non, il ne l'a pas réparé, j'ai juste ce bug. C'est la première fois depuis l'installation de 15.04, mais ce n'est pas du tout amusant. - conualfy
se passe encore dans 16.04 - vorburger
Toujours sur 16.04 ici aussi.
se passe toujours le 17.04 - Rishabh Agrahari


J'ai parfois ce problème avec Ubuntu 15.04 aussi. Une solution rapide et sale consiste à redémarrer X (sudo service lightdm restart)

Sachez que cela tue toutes vos applications ouvertes et vous perdrez toutes les données qui n'ont pas été enregistrées.


-1
2018-06-04 10:07