Question Qualité sonore médiocre sur Ubuntu


Sur Ubuntu (toutes les versions que j'ai essayées depuis ~ 2009 ou 2008), la qualité sonore est sensiblement différente de celle de Windows XP, indépendamment de quel programme j'utilise pour la lecture (YouTube, écoute de MP3, Spotify, etc.)

Le son est nettement pire et moins naturel sur Ubuntu: mon portable ressemble un peu à une boîte de conserve (faute d’une meilleure façon de le décrire), et lorsque le volume est modérément élevé, le boîtier de l’ordinateur portable résonne horrible, et ne se produit jamais sur Windows XP, même au volume le plus élevé).

Notez s'il vous plaît--- ce n'est pas une différence de qualité subjective: le boîtier de l'ordinateur portable résonnera sur Ubuntu dès que le volume atteindra le niveau moyen. Il ne fonctionne pas sous Windows, même au volume maximum.

Quelques informations supplémentaires sur ma configuration

L'ordinateur est un Dell Inspiron 6000, avec un son "SigmaTel C Major Audio". Sous Windows, j'utilise les pilotes par défaut de Dell, je n'ai modifié aucun paramètre, et j'ai vérifié qu'aucun traitement audio supplémentaire n'est activé (par exemple, amplification 3D ou basse ou tout ce qui est disponible sur certains ordinateurs). Sur Ubuntu 11.10, j'utilise également les valeurs par défaut. Il n'y a pas de différence notable dans le son le volume de Ubuntu et WinXP.

Des questions

  1. Pourquoi y a-t-il une différence de qualité sonore?

    Les données audio envoyées par les programmes ne sont-elles pas "rendues" aux enceintes telles quelles? Existe-t-il un traitement supplémentaire, peut-être pour compenser les caractéristiques des haut-parleurs ou de la mallette d'ordinateur portable, semblable à la gestion de la couleur?

  2. Que puis-je faire pour résoudre ce problème et rendre Ubuntu aussi naturel que Windows XP sur mon ordinateur portable?


16
2017-11-04 10:05


origine


Si vous vous sentez ambitieux, vous pouvez essayer de démonter le portable suffisamment pour que les haut-parleurs soient lâches, puis remplissez les fissures avec Blu-tack ou tout produit similaire. Je le fais avec mon téléphone portable qui est un peu plus facile que de le faire avec un lappy. Fonctionne bien, cependant. Plus de résonance de l'affaire. - Tom Brossman
@Tom Merci pour la suggestion, mais je préfère ne pas le démonter --- J'espère toujours une solution logicielle. Je soupçonnais que quelque chose n'allait pas avec le pilote sur Ubuntu. - Szabolcs
Pour le diagnostic, avez-vous essayé un Live CD d'Ubuntu ou une autre distribution, à savoir: Puppy juste pour "VOIR" s'il y avait vraiment une différence? Je ne peux pas dire si les fréquences de résonance diffèrent dans Windows 7 vs Ubuntu mais je suppose que tout est possible. Une autre chose à considérer est la différence entre les haut-parleurs externes attachés? Il faut y penser! - Ringtail
J'ai eu de bons résultats dans le passé en vérifiant que toute préamplification était abaissée, mais je ne sais pas comment faire en 11.10, cela fonctionne simplement. Peut-être essayer d'installer Pavucontrol à partir du Software Center et voir si cela peut réduire le surmodulation. Pas d'idées maintenant, bonne chance ... - Tom Brossman
@Tom "pré-amplification" <- qu'est-ce que c'est? Est-ce une amplification (numérique) basée sur un logiciel? Je ne pense pas que WinXP a cela, alors peut-être que cela pourrait être la source du problème. Je vais google pour ça. - Szabolcs


Réponses:


La même chose m’est arrivée quand j’utilisais Ubuntu pour la première fois. La raison pour moi était que Ubuntu avait un volume de haut-parleurs trop élevé. Résoudre ce problème est très facile:

  • À l’aide du témoin sonore, ouvrez Paramètres du son et définissez le curseur du volume sonore sur «non amplifié», comme indiqué dans l’image:

sound control panel

J'espère que cela résout le problème.


6
2018-04-21 05:20



Je pense que vous avez peut-être raison à ce sujet! - Szabolcs
@Szabolcs l'avez-vous essayé - user49557
Donnez-moi un peu plus de temps. Si cela s'avère être la solution, j'accepterai. - Szabolcs
Cela ne m'a pas aidé :( - Patryk
@Patryk s'il vous plaît demander une nouvelle et mettre toutes vos informations sur vos paramètres sonores et collez l'URL de la question ici, je serai heureux de vous aider - user49557


S'il vous plaît vérifier vos paramètres de mixage, j'ai une expérience totalement différente, dans Windows 7, mon netbook sonne muet alors que dans Ubuntu, il prend vie avec plus d'imagerie.


1
2018-02-28 09:32



Pouvez-vous être plus précis sur les paramètres auxquels vous faites référence? Je préfère éteindre tout pré-traitement des données sonores avant leur sortie. Je crois que j'ai réussi à le faire sous Windows XP. Comment puis-je faire cela aussi dans Ubuntu? - Szabolcs


Avez-vous essayé d'installer alsa-hda-dkms à partir du dépôt ppa: ubuntu-audio-dev / alsa-daily?

Travaillé pour moi quand mon portable commençait à se déformer comme un bidon.


1
2018-03-02 13:27





J'ai remarqué la même différence audio que vous avez.

Je ne me souviens pas du nom de celui-ci pour le moment (je n'ai pas utilisé Windows depuis longtemps), mais je pense qu'il existe un processeur audio qui améliore l'audio sous Windows. Je me rappelle avoir vu quelque chose dans le panneau de commande à ce sujet. Encore une fois, je suis peut-être fou. :-P

Si vous ne voyez rien qui ressorte du panneau de contrôle, exécutez alsamixer sur Ubuntu, et vérifiez vos niveaux de cette façon.

Bonne chance!


1
2018-04-21 05:04



Merci pour le commentaire --- Je suis certain qu'il n'y a pas de traitement audio spécial activé sous Windows dans ce cas. Je me suis assuré que tout était éteint. - Szabolcs
Merci. changer la carte son dans alsamixer corrigé pour moi - Ben Yitzhaki


J'ai Ubuntu 14.04 sur Macbook Pro 9,1. J'ai résolu le problème en allant dans "Paramètres système" -> "Son" Et en sélectionnant "Speakers: Built-in Audio" dans l'option "Play sound through" correct option --> Speakers: Built-in Audio. A l'origine, la "sortie analogique" avait été sélectionnée. Cela a corrigé instantanément mes problèmes de son et donné un son plus net.


1
2017-07-30 10:46





J'ai eu un problème similaire avec Ubuntu 14.04 et mes écouteurs. L'installation d'égaliseurs n'a pas aidé. Il n'y avait tout simplement pas de basse! Dans mon cas, la solution était simple: Il y avait une énorme différence entre la prise audio avant et arrière de mon PC! La prise frontale (pour les écouteurs) était bien meilleure. Donc, essayez simplement d'utiliser l'autre prise?


1
2017-09-28 13:47





Dans Ubuntu, avez-vous essayé de changer le paramètre d'accélération «3D» de la carte son? Il a peut-être été défini par défaut sur le paramètre 3D, ce qui peut avoir amplifié certaines fréquences pour ajouter une image stéréo aux haut-parleurs de l’ordinateur portable. Comment cela sonne-t-il avec un casque lorsque vous le comparez sous Windows?


0
2018-02-27 22:03



Pouvez-vous donner quelques conseils sur où trouver ce paramètre? Je n'ai pas pu le trouver dans la boîte de dialogue des paramètres sonores du 11.10. - Szabolcs
@Szabolcs Je ne pense pas que ce paramètre existe, sonne comme une chose de Windows Media Player. - Tom Brossman
Vous pouvez installer alsa mixer depuis le centre logiciel et accéder aux paramètres de votre carte son. - rylhunt


Vous pouvez essayer Open Sound System (OSSv4) avec une qualité de production activée dans ossxmix. Malheureusement, il est nécessaire de le construire à partir des sources et de supprimer ALSA, PulseAudio de votre Ubuntu et de définir des applications pour OSSv4.

Vous devez publier la sortie de la commande lspci -v (exécutez-la dans le terminal) pour la section périphérique audio. Lorsque vous saurez quelle est votre carte son, vous pouvez vérifier si elle est supportée par Système audio ouvert.

Documentation de la communauté Ubuntu concernant OpenSound possède des commandes pour supprimer ALSA (redémarrage requis) et, bien sûr, pour installer OSSv4 (y compris la compilation à partir des sources). Il y a aussi le guide officiel concernant ce processus. Avant de commencer la compilation, ouvrez l'application software-properties-gtk en tant que root et vérifiez le code source dans le premier onglet. Ensuite, mettez à jour vos sources de logiciels et exécutez cette commande:

sudo apt-get build-dep oss4-base

Vous devez changer le script de configuration GRC_MAX_QUALITY = 3 à GRC_MAX_QUALITY = 6 pour le rééchantillonneur de qualité de production. Sachez que vous pouvez créer le package .deb.

Quand tout est fait, il est temps de configuration des applications. Vous pouvez également émuler ALSA pour les applications qui ne supportent pas OSSv4 éditer /etc/asound.conf ou .asoundrc selon les instructions sur Wiki Arch Linux OSSv4.


0
2018-02-29 19:25



Open Sound System est nettement supérieur en termes de qualité sonore, mais vous risquez malheureusement d’avoir des problèmes d’enregistrement. Je ne peux pas le comprendre sur ma machine. - Mateusz Stachowski
Qu'entendez-vous exactement par un attribut de qualité sonore médiocre pour PulseAudio et ALSA? Pouvez-vous sauvegarder vos réclamations? - zetah
C'est ce que je pense lorsque l'on compare PA et ALSA à OSSv4 avec le ré-échantillonnage de qualité de production activé. Open Sound System sonne beaucoup mieux, beaucoup mieux pour moi. - Mateusz Stachowski
Penser ne suffit pas. Vous devez faire un ABX tester être pris au sérieux. Veuillez revoir votre réponse (avec votre réponse précédente, que vous dupliquez) et supprimer les réclamations comme trompeuses. Quelque chose d'autre est défectueux dans votre pipeline audio et vous feriez mieux de trouver quoi, au lieu d'accuser quelque chose que vous ne comprenez pas - zetah
Qu'est-ce qui pourrait causer la différence? Ce que je ne comprends toujours pas, c'est pourquoi les données sonores émises par les programmes ne sont pas envoyées au matériel tel quel et quel type de traitement se produit avant qu'il n'atteigne la carte son. J'ai googlé un peu sur ALSA et OSSv4 et j'ai trouvé que OSS4 a un mélange supérieur. Mais si un seul programme est en cours de sortie, je suppose que le mixeur devrait introduire des distorsions minimales à nulles. Quoi qu'il en soit, je vais essayer de passer d'ALSA à OSSv4, juste pour voir si cela change quelque chose. Je doute en quelque sorte que le mixeur seul puisse avoir un impact aussi important que ce que j'entends, mais ... - Szabolcs