Question Alienware R5 17 ordinateur portable se bloque sur la suspension


Cela se produit à la fois avec le noyau Ubuntu 4.15 et le noyau 4.18.5 mis à jour pour que l'interface wifi fonctionne. (Mis à jour en utilisant uuku)

Les choses que j'ai essayées:

  • Installer les derniers pilotes nvidia avec l'autoinstall
    • Faire cette liste noire le pilote nouveau qui est la source de nombreux messages sur le sujet.
    • La désactivation du service nvidia-fallback.service provoque l'affichage en noir du système lors de la connexion. J'ai donc réactivé ce service.

Je ne trouve rien de suspect dans les journaux.


2
2017-09-09 19:37


origine


Il me semble que j'avais aussi ce problème en testant 18.04. Avec 16.04.5 suspendre avec les pilotes nVidia 384.130 fonctionne bien Avez-vous un NVMe M.2 SSD Gen 3.0x4 installé? Si oui, voyez ceci: askubuntu.com/questions/981657/cannot-suspend-with-nvme-m-2-ssd/… - WinEunuuchs2Unix
je faire avoir cette marque de SSD! Merci beaucoup pour le lien! Faites-en une réponse pour que je puisse la corriger si cela fonctionne et vous donner les points :) - Christopher Patti
Merci. J'ai posté une réponse. - WinEunuuchs2Unix


Réponses:


Dans de rares cas, lorsque vous reprenez après la suspension, les SSD NVMe M.2 ne sont plus alimentés s'ils sont des voies de bus Gen 3.0 x 4. Bien que cela ait été promis dans une ancienne version du noyau, elle n’est pas encore apparue: Impossible de suspendre avec le SSD NVMe M.2

Si vous avez un tel SSD, essayez ce qui suit:

modifier /etc/default/grub avec sudo pouvoirs et trouver la ligne:

GRUB_CMDLINE_LINUX_DEFAULT="quiet kaslr acpiphp.disable=1 pcie_aspm=off nloglevel=3 udev.log-priority=3"

Vos options seront différentes mais ajoutez l'option acpihp.disable=1 entre les guillemets doubles.

Enregistrez le fichier et exécutez sudo update-grub.

Redémarrer puis suspendre et reprendre fonctionnera.


1
2017-09-09 23:33



Hrrm. Merci, je n'ai pas encore eu de chance avec ça. - Christopher Patti
J'ai édité mon / etc / default / grub comme ceci: GRUB_CMDLINE_LINUX_DEFAULT = "acpiphp.disable calme = 1 splash" - Christopher Patti
Ce n'est pas le problème mais c'est la tradition de mettre de nouvelles variables après quiet splash donc ça ressemblerait à: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpiphp.disable=1". Comme je l'ai mentionné précédemment, j'ai eu des problèmes de suspension dans 18.04 qui est l'une des raisons pour lesquelles j'utilise 16.04 au lieu. Il se peut très bien que vous ayez d'autres problèmes à part / au lieu du SSD NVMe. - WinEunuuchs2Unix
@ChristopherPatti Sorry vient de remarquer la commande sudo update-grub manquait. Je l'ai ajouté à la réponse. - WinEunuuchs2Unix