Question Comment activer numlock au démarrage pour l'écran de connexion?


J'essaye de forcer numlock à être activé au démarrage initial sur l'écran de connexion sur Ubuntu 12.04. Les seules solutions que j'ai trouvées jusqu'ici n'activent le numlock qu'après la connexion initiale.

Je cherche à activer numlock lorsque l'écran de connexion est affiché et avant que l'utilisateur ne soit connecté. Quelqu'un peut-il aider?


88
2018-06-25 07:42


origine


est-ce lors de l'ouverture de session sur lightdm ou après s'être connecté sous l'unité? parce que je sais la solution à la fois - sarveshlad
De darryn.ten - PAS une copie exacte, car j'ai besoin de numlock AVANT de me connecter pas après. - Jjed


Réponses:


Sur de nombreuses machines, vous pouvez définir si Verrouillage numérique est activé au démarrage, dans les paramètres du BIOS (accessible lorsque vous allumez la machine pour la première fois).

Sinon, il existe plusieurs moyens d’activer (ou de désactiver) Verrouillage numérique dans le logiciel, en fonction de vos besoins spécifiques. Les moyens les plus utiles sont listés ici.

Si tu veux Verrouillage numérique activé lorsque Ubuntu démarre (pas avant que dans le menu GRUB, et pas après lors de la connexion, et pas seulement pour des consoles virtuelles spécifiques), puis installez numlockx et faire le script d'initialisation /etc/rc.local l'utiliser pour activer Verrouillage numérique:

sudo apt-get update
sudo apt-get -y install numlockx
sudo sed -i 's|^exit 0.*$|# Numlock enable\n[ -x /usr/bin/numlockx ] \&\& numlockx on\n\nexit 0|' /etc/rc.local

La source: NumLock, par Contributeurs au wiki de la documentation Ubuntu, dernière ligne prise textuellement (comme cette source permet).


58
2018-06-25 07:48



J'ai donc suivi les instructions sur la page du wiki à laquelle vous vous êtes connecté. J'ai fait la commande de mise à jour que vous listez ici. J'ai fait sudo apt-get install numlockx. Mais je n'ai pas utilisé l'option y. Est-ce nécessaire? Je n'ai rien dit à ce sujet sur la page du wiki, alors je n'ai rien fait. J'ai redémarré et tout sauf Numlock est toujours désactivé au démarrage et à l'écran de connexion. Va essayer la commande de mise à jour. A part ça, est-ce que je manque quelque chose d'autre ici? L'option "touches du pavé numérique par défaut" des préférences du clavier ne concerne pas les paramètres de démarrage, donc je ne l'ai pas activée. Devrais-je? - Samir
Cela n'a pas fonctionné pour moi. Réponse de Luvr cependant. - Clarkey
Cela ne fonctionne plus sur Xubuntu LTS 12.04. - Serge Stroobandt
L'option -y est pour forcer la réponse "Oui" si apt-get question pour l'installer. BECAREFUL WITH THIS: parfois - je pense que ce n'est pas le cas, du moins pas dans mon cas - il y a des cas où apt-get dit qu'il faut enlever quelque chose; dans ce cas, apt-get vous demandera de confirmer cette action. Mais, supprimer parfois des paquets automatiquement en utilisant apt causerait plusieurs problèmes sur votre machine. Par exemple, vous demandez parfois de supprimer certains packages graphiques utilisés pour les interfaces graphiques. Même parfois, il m'a demandé de supprimer gnome-desktop et certains pilotes gpu ... qui vont vraiment gâcher SO - Diego Andrés Díaz Espinoza


Voici ce qui a fonctionné pour moi:

  1. Assurez-vous que numlockx est installé:

    sudo apt-get install numlockx
    
  2. Editez le fichier /etc/lightdm/lightdm.conf

    gksudo gedit /etc/lightdm/lightdm.conf
    
  3. Ajoutez la ligne suivante au fichier:

    greeter-setup-script=/usr/bin/numlockx on
    

36
2018-04-29 20:11



Comment puis-je vérifier que numlockx est installé? Devrait-il apparaître sur une recherche de tableau de bord? - Samir
Dois-je enlever greeter-session=unity-greeter ou la session utilisateur = ubuntu` du fichier (lightdm.conf)? Ou juste la ligne greeter-setup-script en dessous d'eux? - Samir
Sur Ubuntu 13.10, cette méthode empêchait l'affichage de l'écran de connexion sur ma machine. Après l'affichage initial du logo Ubuntu, le moniteur montrait simplement qu'il n'y avait pas de signal (j'ai essayé de redémarrer plusieurs fois, mais le résultat était toujours le même). Ne sachant pas quoi faire d'autre, j'ai démarré le système à partir d'une clé USB en direct et supprimé la ligne de lightdm.conf. Après cela, le système s'est rechargé correctement. - tmt
Bien que je sache que cette astuce a fonctionné pour moi dans les versions antérieures, elle ne semble plus fonctionner en 14.04. L'ajout de cette ligne à lightdm.conf interrompt le processus de connexion en m'envoyant en mode Low Graphics et en empêchant une connexion avec les pilotes Nvidia. Supprimer cette ligne a résolu le problème. - cowbell40
Je n'ai pas le fichier /etc/lightdm/lightdm.conf Mais j'ai ça /etc/lightdm/lightdm.conf.d/70-linuxmint.conf et il fonctionne!!! :RÉ - Shayan


14.04

Oui, utiliser locate commande comme suit:

locate 50-unity-greeter.conf

La sortie est la suivante:

/usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf

Le fichier à modifier est donc le fichier ci-dessus.

sudo apt-get install numlockx
gksu gedit /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf

Ajoutez cette ligne à la fin du fichier:

greeter-setup-script=/usr/bin/numlockx on

22
2018-04-02 11:42



Quelle est la différence entre / usr / share / lightdm / et / etc / lightdm? Les paramètres de l'ancien dossier ne seraient-ils pas remplacés par des mises à jour, alors que dans le second ils ne le seraient pas ou ai-je mal compris la signification des dossiers? - Peter Raeves
@ PeterRaeves: Vous avez absolument raison. Radu, je vous suggère de modifier votre réponse en conséquence. L'édition d'un fichier de package qui n'est pas sous / etc ne peut être qu'un hack temporaire. - Gunnar Hjalmarsson
Celui-ci a travaillé pour moi - abhishah901
C'est la réponse la plus proche qui m'a aidé. j'utilise Xubuntu 14.04 et le fichier était /etc/lightdm/lightdm.conf.d/10-xubuntu.conf et j'ai ajouté le greeter-setup-script=/usr/bin/numlockx on à la fin de ce fichier et cela a fonctionné très bien! +1 pour m'avoir orienté dans la bonne direction! - Terrance
en 16.04 beta2 cela mènera à ce problème askubuntu.com/questions/141606/… - Geng Jiawen


Pour l'activer sur l'écran de connexion 

Tout d'abord, assurez-vous que numlockx est installé, en les tapant dans le terminal:

sudo apt-get install numlockx

Ensuite, éditez le fichier /etc/lightdm/lightdm.conf

gksudo gedit /etc/lightdm/lightdm.conf

Ajoutez la ligne suivante au fichier:

greeter-setup-script=/usr/bin/numlockx on

Pour activer le verrouillage numérique par défaut après la connexion ..

  1. Dans Dash Search for Clavier et l'ouvrir
  2. Dans la fenêtre qui s'ouvre sur la poubelle à droite il y a Les options, Clique dessus.
  3. En dessous de Options de compatibilité diverses, Activer Touches numériques par défaut.

enter image description here


14
2018-05-02 17:20



ce n'est pas ce cas, je fais cette procédure en passant. J'appuie sur le bouton "Num Lock" et immédiatement il s'éteint, "ne reste pas allumé". J'avais vérifié le clavier et c'est ok dans une autre machine et d'autres outils. Je change le clavier en un ancien clavier ps / 2 pour tester. Il semble que cela fonctionne, à savoir, il y a un problème avec le clavier USB dans Ubuntu 12.04 - Brunno


Je l'ai fait et cela a fonctionné pour moi. Tout d'abord, assurez-vous d'avoir ajouté le référentiel d'univers.

Appuyez simplement sur Ctrl+Alt+T sur votre clavier pour ouvrir le terminal. Lorsqu'il s'ouvre, exécutez les commandes ci-dessous.

sudo apt-get update
sudo apt-get install numlockx

Maintenant que numlockx est installé, créez un fichier nommé Default dans /etc/X11/ avec ces contenus:

if [ -x /usr/bin/X11/numlockx ]; then
    /usr/bin/X11/numlockx on
fi

exit 0

Éteignez votre Verrouillage numérique et redémarrer. Voilà!


6
2018-06-25 08:42



ne fonctionne pas en 18.04 - equitharn


Xubuntu spécifique.

Les versions de 14.10 incluent une action pkexec mousepad.

Suivez les réponses précédentes pour installer numlockx

Editez /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf en tant que root

Alt + F2 puis

pkexec mousepad /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf

Ajouter

greeter-setup-script = / usr / bin / numlockx on

puis sauvegardez.


4
2018-02-22 15:31





La plupart des BIOS permettent que ceci soit activé. Vous pouvez vérifier votre BIOS pour cette fonctionnalité.

OU

Allez à: Paramètres système -> Disposition du clavier -> Options -> Options de compatibilité diverses

Cochez "Clés numériques par défaut"

Sources : https://help.ubuntu.com/community/NumLock


2
2018-02-11 06:11



J'ai abandonné ... merci - 신영민


Voici un peu bash script qui s'occupe de tout de manière automatisée:

#!/usr/bin/env bash
FILE='/etc/lightdm/lightdm.conf'
KEYVALUE='greeter-setup-script=/usr/bin/numlockx on'
sudo apt-get --yes install numlockx
grep --quiet "$KEYVALUE" "$FILE" || echo "$KEYVALUE" | sudo tee --append "$FILE"

N'oubliez pas de faire d'abord votre bash script exécutable avec chmod +x scriptname, puis l'exécuter avec ./scriptname.


1
2018-05-09 17:01