Question Comment régler ce problème?


J'utilise Ubuntu 16.04, chaque fois que j'ai essayé de mettre à niveau, j'ai une erreur

sudo apt-get upgrade
[sudo] password for nikhil: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libpython3.6-stdlib : Breaks: python3-tk (< 3.6.4~rc1-2) but 3.6.3-0ubuntu1~16.04.york0 is installed
E: Unmet dependencies. Try using -f.
nikhil@nikhil-desktop:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  aria2 gyp libc-ares2 libdb5.3:i386 libgcrypt20:i386 libjs-inherits
  libjs-node-uuid libsystemd0:i386 libudev1:i386 libuv1 libuv1-dev
  linux-headers-4.13.0-38 linux-headers-4.13.0-38-generic
  linux-image-4.13.0-38-generic linux-image-extra-4.13.0-38-generic
  node-abbrev node-ansi node-ansi-color-table node-archy node-async
  node-block-stream node-combined-stream node-cookie-jar node-delayed-stream
  node-forever-agent node-form-data node-fstream node-fstream-ignore
  node-github-url-from-git node-glob node-graceful-fs node-gyp node-inherits
  node-ini node-json-stringify-safe node-lockfile node-lru-cache node-mime
  node-minimatch node-mkdirp node-mute-stream node-node-uuid node-nopt
  node-normalize-package-data node-npmlog node-once node-osenv node-qs
  node-read node-read-package-json node-request node-retry node-rimraf
  node-semver node-sha node-sigmund node-slide node-tar node-tunnel-agent
  node-underscore node-which
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  python3-tk
Suggested packages:
  tix python3-tk-dbg
The following packages will be upgraded:
  python3-tk
1 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Need to get 0 B/97.5 kB of archives.
After this operation, 308 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 402176 files and directories currently installed.)
Preparing to unpack .../python3-tk_3.6.5-3~16.04.york0.2_amd64.deb ...
Unpacking python3-tk:amd64 (3.6.5-3~16.04.york0.2) over (3.6.3-0ubuntu1~16.04.york0) ...
dpkg: error processing archive /var/cache/apt/archives/python3-tk_3.6.5-3~16.04.york0.2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/python3.6/lib-dynload/_tkinter.cpython-36m-x86_64-linux-gnu.so', which is also in package python3.6-tk:amd64 3.6.5-1+xenial1
Errors were encountered while processing:
 /var/cache/apt/archives/python3-tk_3.6.5-3~16.04.york0.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

J'ai aussi essayé de faire

nikhil@nikhil-desktop:~$ sudo apt autoremove
[sudo] password for nikhil: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libpython3.6-stdlib : Breaks: python3-tk (< 3.6.4~rc1-2) but 3.6.3-0ubuntu1~16.04.york0 is installed
E: Unmet dependencies. Try using -f.
nikhil@nikhil-desktop:~$ sudo apt install -f 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  aria2 gyp libc-ares2 libdb5.3:i386 libgcrypt20:i386 libjs-inherits
  libjs-node-uuid libsystemd0:i386 libudev1:i386 libuv1 libuv1-dev
  linux-headers-4.13.0-38 linux-headers-4.13.0-38-generic
  linux-image-4.13.0-38-generic linux-image-extra-4.13.0-38-generic
  node-abbrev node-ansi node-ansi-color-table node-archy node-async
  node-block-stream node-combined-stream node-cookie-jar node-delayed-stream
  node-forever-agent node-form-data node-fstream node-fstream-ignore
  node-github-url-from-git node-glob node-graceful-fs node-gyp node-inherits
  node-ini node-json-stringify-safe node-lockfile node-lru-cache node-mime
  node-minimatch node-mkdirp node-mute-stream node-node-uuid node-nopt
  node-normalize-package-data node-npmlog node-once node-osenv node-qs
  node-read node-read-package-json node-request node-retry node-rimraf
  node-semver node-sha node-sigmund node-slide node-tar node-tunnel-agent
  node-underscore node-which
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  python3-tk
Suggested packages:
  tix python3-tk-dbg
The following packages will be upgraded:
  python3-tk
1 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Need to get 0 B/97.5 kB of archives.
After this operation, 308 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 402176 files and directories currently installed.)
Preparing to unpack .../python3-tk_3.6.5-3~16.04.york0.2_amd64.deb ...
Unpacking python3-tk:amd64 (3.6.5-3~16.04.york0.2) over (3.6.3-0ubuntu1~16.04.york0) ...
dpkg: error processing archive /var/cache/apt/archives/python3-tk_3.6.5-3~16.04.york0.2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/python3.6/lib-dynload/_tkinter.cpython-36m-x86_64-linux-gnu.so', which is also in package python3.6-tk:amd64 3.6.5-1+xenial1
Errors were encountered while processing:
 /var/cache/apt/archives/python3-tk_3.6.5-3~16.04.york0.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Comment puis-je résoudre ce problème ou supprimer ce package?


2
2018-05-13 08:28


origine


S'il vous plaît essayer ceci sudo apt full-upgrade pour le faire enlever tout paquet qui doit être enlevé! - George Udosen
nikhil @ nikhil-desktop: ~ $ sudo apt mise à jour complète [sudo] mot de passe pour nikhil: lecture des listes de paquets ... Terminé Arbre de dépendance de construction Lecture des informations d'état ... Terminé Vous pouvez lancer 'apt-get -f install' pour les corriger. Les paquets suivants ont des dépendances non satisfaites: libpython3.6-stdlib: Breaks: python3-tk (<3.6.4 ~ rc1-2) mais 3.6.3-0ubuntu1 ~ 16.04.york0 est installé E: dépendances non satisfaites. Essayez d'utiliser -f. - Nikhil R
Vous devriez utiliser un titre plus descriptif pour que les personnes ayant des problèmes similaires puissent le trouver plus facilement. - SurvivalMachine
Après avoir corrigé mon problème, je changerai le titre, je ne sais pas quel est le problème? Je suis nouveau sur Ubuntu @SurvivalMachine, comment puis-je résoudre ce problème? - Nikhil R
S'il vous plaît courir sudo apt install -f et ajoutez toujours les résultats sous forme de modification à votre message et non dans les commentaires! - George Udosen


Réponses: