Question Impossible d'installer Virtualbox 5.1 sur Ubuntu 16.04


Je suis incapable d'installer Virtualbox5.1 de l'oracle ppa; avec l'erreur suivante

The following packages have unmet dependencies:
 virtualbox-5.1 : Depends: libqt5core5a (>= 5.6.0~beta) but 5.5.1+dfsg-16ubuntu7.2 is to be installed
                  Depends: libqt5widgets5 (>= 5.6.0~beta) but 5.5.1+dfsg-16ubuntu7.2 is to be installed
                  Depends: libqt5x11extras5 (>= 5.6.0) but 5.5.1-3build1 is to be installed
                  Recommends: libsdl-ttf2.0-0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

2
2018-03-29 15:21


origine


Courir sudo apt install -f. - Pilot6
On dirait que cela a été répondu ici. askubuntu.com/questions/898054/… - saviour123
@ Pilot6 Je ne veux pas forcer la mise à jour - Sarvex
@ saviour123 la question a trait à la virtualbox par défaut 5.0, alors que je rencontre des problèmes avec Oracle PPA fournissant 5.1 - Sarvex
J'utilise VB 5.1 sans aucun problème. J'ai installé un fichier deb et le PPA a été ajouté automatiquement. - Pilot6


Réponses:


Ce sont toutes les dépendances pour la plus récente VirtualBox 5.1.18 installée à partir du Référentiel Oracle pour Ubuntu 16.04.2 LTS:

Dependencies:
5.1.18-114002~Ubuntu~xenial - debconf (18 1.1) debconf-2.0 (0 (null)) libc6 (2 2.15) libcurl3 (2 7.16.2) libdevmapper1.02.1 (2 2:1.02.97) libgcc1 (2 1:3.0) libgl1-mesa-glx (16 (null)) libgl1 (0 (null)) libpng12-0 (2 1.2.13-4) libpython2.7 (2 2.7) libqt5core5a (2 5.5.0) libqt5gui5 (18 5.3.0) libqt5gui5-gles (2 5.3.0) libqt5opengl5 (18 5.0.2) libqt5opengl5-gles (2 5.0.2) libqt5printsupport5 (2 5.0.2) libqt5widgets5 (2 5.2.0) libqt5x11extras5 (2 5.1.0) libsdl1.2debian (2 1.2.11) libssl1.0.0 (2 1.0.0) libstdc++6 (2 5.2) libvpx3 (2 1.5.0) libx11-6 (0 (null)) libxcb1 (0 (null)) libxcursor1 (4 1.1.2) libxext6 (0 (null)) libxinerama1 (0 (null)) libxml2 (2 2.7.4) libxmu6 (0 (null)) libxt6 (0 (null)) zlib1g (2 1:1.1.4) psmisc (0 (null)) adduser (0 (null)) virtualbox (0 (null)) virtualbox:i386 (0 (null)) virtualbox-guest-additions-iso (0 (null)) virtualbox-guest-additions-iso:i386 (0 (null)) virtualbox-ose (0 (null)) libasound2 (0 (null)) libpulse0 (0 (null)) libsdl-ttf2.0-0 (0 (null)) kmod (16 (null)) kldutils (16 (null)) module-init-tools (0 (null)) linux-headers-generic (16 (null)) linux-headers-generic-pae (16 (null)) linux-headers-686-pae (16 (null)) linux-headers-amd64 (16 (null)) linux-headers-2.6-686 (16 (null)) linux-headers-2.6-amd64 (16 (null)) linux-headers (0 (null)) linux-image (0 (null)) gcc (0 (null)) make (16 (null)) build-essential (16 (null)) dpkg-dev (0 (null)) binutils (0 (null)) pdf-viewer (0 (null)) libgl1 (0 (null)) virtualbox (0 (null)) virtualbox:i386 (0 (null)) virtualbox-5.1:i386 (32 (null)) 
Provides: 
5.1.18-114002~Ubuntu~xenial - virtualbox (= ) 

De cela, nous pouvons voir que tous les paquets dépendants sont disponibles via l'installation par défaut. Pas besoin d'installer une version ultérieure du paquet.

Vous avez peut-être téléchargé ou installé accidentellement une version de Virtual Box conçue pour Ubuntu 16.10 ou une autre distribution. S'il vous plaît voir cette réponse sur la façon d'ajouter le référentiel Oracle à vos sources et assurez-vous d'utiliser la version Ubuntu appropriée pour la ligne des sources:

lsb_release -sc

0
2018-03-29 20:17





Dans votre /etc/apt/sources.list: remplacer 'deb http://download.virtualbox.org/virtualbox/debian yakkety contrib ' par 'deb http://download.virtualbox.org/virtualbox/debian xenial contrib '


0
2017-10-11 07:50