Question Appareil sans fil non prêt après la mise à niveau vers 16.04


J'ai mis à niveau vers Lubuntu 16.04 et le sans fil ne fonctionne pas. Cela a fonctionné en 14.04.

lspci | grep Wireless
09:00.0 Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe

Dans NM, les options Activer la mise en réseau et Activer la connexion sans fil sont toutes deux cochées, mais on peut y lire: Réseaux Wi-Fi / Périphérique non prêt.

rfkill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

J'ai couru sans fil-info, les résultats sont dans http://paste.ubuntu.com/23061345/

J'ai aussi édité /etc/NetworkManage/NetworkManager.conf, le paramétrage a réussi à true

[ifupdown]
managed=true

J'ai l'impression que tout ce que j'ai à faire est de décharger un mauvais module et de charger le bon, mais je suis un peu désorienté à ce sujet. Quelqu'un peut-il aider?

MODIFIER

Je ne suis vraiment pas disposé à ajouter ceci comme réponse parce que la procédure est complètement folle, alors je modifie juste la question. J'espère encore plus que quelqu'un puisse expliquer ce qui s'est passé. Le sans fil fonctionne maintenant - je l'utilise actuellement. Je spécifie ce que j'ai fait étape par étape.

  • Depuis que le sans fil a fonctionné en 14.04, j'ai fait un live usb de Lubuntu 14.04.3. Mon plan était de lancer des informations sans fil à partir de là, puis de comparer ses résultats avec la version 16.04. J'ai utilisé un lecteur USB récemment formaté - pas de persistance, l'option même a disparu de la version 16.04 de Startup Disc Creator.

  • Éteindre le PC, allumer avec lecteur USB en place.

  • Ubuntu démarre et se charge la nouvelle version, soit 16.04, même si le lecteur USB clignote continuellement. Le sans fil ne fonctionne pas. Le système de fichiers qui apparaît dans PcManFM est celui de mon disque dur, pas celui du disque USB. Le lecteur USB est invisible dans PcManFM.

  • Arrêt, branchez le lecteur USB, allumez.

  • Lubuntu 16.04 commence et le sans fil fonctionne parfaitement. Vérifiez le lecteur USB avec gparted: il signale un système de fichiers non reconnu. Je supprime la partition, formate le lecteur USB pour les données, vérifie et vérifie son intégrité; c'est bon.

C'est sûrement bizarre. Certains dysfonctionnements dans Startup Drive Creator ont réparé un dysfonctionnement avec le sans fil. Je ne recommanderais en aucun cas cela comme une solution, pas même une solution heuristique. La seule chose raisonnable que je puisse faire est de coller l'URL du nouveau texte d'information sans fil: http://paste.ubuntu.com/23061620/

La comparaison est frappante. Les mêmes modules, avec les mêmes paramètres. Mais, dans le cas présent, wlan0 reçoit une adresse inet alors que dans le cas contraire, l'adresse est pour eth0. Mais la raison en est pour moi totalement obscure. Peut-être devrait-on débrancher le câble Ethernet avant de démarrer le PC?

(En dehors de cela, je suggère qu'une attention sérieuse devrait également être accordée au fait que Startup Disc Creator produit des clés USB qui bricolent en quelque sorte le système d'exploitation.)


2
2017-08-16 12:39


origine


Regarde aussi askubuntu.com/questions/545238/…


Réponses: