Question comment installer cmake-gui 3?


J'ai cmake 3.2.2 mais cmake-gui affiche 2.8 et certains paquets ne peuvent pas être configurés avec cmake-gui car ils ont demandé la nouvelle version. y a-t-il du temps pour installer cmake-gui 3 ou le faire reconnaître la dernière version installée? Bonne journée! Ibraheem


2
2018-06-20 06:57


origine




Réponses:


le cmake-qt-gui le paquet du dépôt dépend de 2.8 cmake. Pour le faire reconnaître 3.2.2. vous pouvez essayer de jouer avec des liens symboliques en définissant cmake 2.8 lien vers le nouveau cmake. Mais je ne peux pas garantir que cela fonctionnera et douter qu'il aura les mêmes fonctionnalités.

Mais si tu construis cmake de la source, vous pouvez obtenir de nouvelles cmake-gui. Ouvrir bootstrap fichier, faites défiler et définissez:

cmake_bootstrap_qt_gui="1"

Ensuite, configurez, construisez et installez cmake. Il pourrait être préférable de supprimer cmake-qt-gui La version 2.8 d'abord, car je ne suis pas sûr de ce qui se passera si vous avez les deux.


0
2017-09-29 09:53