Question "Ctrl + espace" a été appelé pour invoquer une méthode de saisie et ne fonctionne pas dans Emacs ou Eclipse auto-complete


Dans Emacs exécuter dans le terminal, ctrl+espace est une touche de raccourci standard pour sélectionner une région. Mais sous Ubuntu 12.04, il invoquera une méthode de saisie pour une langue autre que l'anglais. Je me demandais si je pouvais le réserver uniquement pour Emacs?

En dessous de System Settings -> Keyboard -> Shortcuts, Je ne pouvais pas trouver à quoi ctrl+espace a été lié Étrange.

D'autres programmes, en particulier l'auto-complétion dans Eclipse, semblent également avoir un problème de gestion ctrl+espace.


81
2018-01-15 23:55


origine




Réponses:


On dirait que vous avez Ibus en cours d'exécution, qui utilise Ctrl + Espace par défaut pour activer / désactiver l'éditeur d'entrée.

Vous pouvez modifier la touche de raccourci qui lui est attribuée dans les préférences d'Ibus.

enter image description here

Si Ibus s'exécute dans la barre de menus, vous pouvez cliquer avec le bouton droit pour choisir Préférence dans le menu. Si Ibus ne fonctionne pas dans la barre de menus, vous pouvez lancer la boîte de dialogue Préférences à partir du tableau de bord en exécutant Méthodes de saisie au clavier ou du terminal avec ibus-setup.

Mise à jour pour 14.04

ibus-setup n'est plus disponible pour 14.04. Fonctions de l'ancien ibus-setup sont plutôt intégrés dans Paramètres système >> Saisie de texte.

La commutation d’entrée est maintenant définie par défaut sur Super + Espace, mais Ibus peut encore voler le focus de la Contrôle + Espace keybinding et causent d'autres problèmes système, notamment l'auto-complétion dans Eclipse.

L'intégration de la commutation d'entrée Ibus dans les nouveaux paramètres de saisie de texte est toujours en cours, ce qui pose problème car l'ancien paramètre existe toujours dans les coulisses.

Si vous avez mis à jour à partir de 12.04, ibus-settings devrait toujours être disponible.

En 14.04, vous pouvez modifier les paramètres directement dconf-editor.

S'il n'est pas installé:

sudo apt install dconf-editor

Puis naviguez jusqu'à Desktop >> ibus >> général >> raccourci clavier. le trigger et triggers le réglage affichera toujours 'control + space'. Modifier ces paramètres, en faisant attention de laisser des crochets vides [] dans triggers.


119
2018-01-16 00:59



Cela a également corrigé l'autocomplétion ne fonctionnant pas dans Eclipse après la mise à niveau vers xubuntu 14.04 - Brian Laframboise
ma ibus-setup le 14.04 est légèrement différent et n’a pas cette option. - BoppreH
@BoppreH 14.04 a un peu modifié la configuration d’ibus. Je vais le regarder Merci. - chaskes
dconf-editor corrigé mon problème, merci beaucoup @chaskes. - BoppreH
@BoppreH Heureux que cela ait fonctionné. S'il vous plait, soulignez (si vous ne l'avez pas fait). ;) - chaskes


Désactiver le déclencheur IBUS en utilisant la ligne de commande:

gsettings set org.freedesktop.ibus.general.hotkey triggers @as []

Ou si cela ne fonctionne pas, essayez si le premier produit une erreur:

gsettings set org.freedesktop.ibus.general.hotkey triggers []

10
2018-06-24 07:46



La deuxième commande a fonctionné pour moi sur une version personnalisée d’Ubuntu 14.04 (goobuntu), qui corrigeait mon problème de copie / copie ou de copier / coller d’emacs. - rrenaud
La deuxième commande a résolu ce problème pour moi, et il se trouve maintenant dans mon script d'installation pour la configuration des bureaux Ubuntu nouvellement installés. Merci, askubuntu! - Mnebuerquo


ibus ne me cause que des maux de tête. Chaque fois que j'essaie de modifier les paramètres, lorsque je redémarre, le Ctrl + Espace revient. Voici ma solution:

sudo apt-get purge ibus
sudo killall ibus

Maintenant, tout fonctionne jusqu'à ce qu'Ubuntu décide de sa prochaine chose stupide. Peut-être que la lettre «o» correspondra à éteindre l'ordinateur?


4
2018-02-11 12:47



Je viens d'essayer ceci (Ubuntu 14.04.3 LTS). Cela n'a pas aidé. - Keith Thompson
CORRECTION: soit ceci, soit en modifiant les préférences IBus, ou en cours d'exécution dconf-editor, fait travail. Je testais en tapant Ctrl-V Ctrl-Space dans bash; pour une raison quelconque, bash ne l'acceptait pas. Mais Ctrl-Space génère un caractère nul. - Keith Thompson


Après la mise à niveau vers Ubuntu 14.04, j'ai eu le même problème. Ce que j'ai fait.
Dans les préférences d'Ibus: System > Preferences > Keyboard Input Methods.
Il y a une option: Next input method il a été mis à ctrl + espace, j'ai supprimé cela et ensuite tout a commencé à travailler à nouveau.


2
2017-07-24 09:04





Ubuntu Studio 14.04 (XFCE) ici. Je n'ai pas eu de problème avec Autocomplete (Ctrl + Space), mais avec Copy Line (Ctrl + Alt + Down).

Cela a fonctionné pour moi:

  • Ouvrez le Gestionnaire Windows: xfwm4-settings
  • Aller à l'onglet Clavier
  • Faites défiler jusqu'à l'action en conflit
  • Appuyez sur le bouton Effacer ou modifiez l'action en un raccourci différent

1
2018-04-04 11:34



Merci! Cela peut être fait sur la ligne de commande aussi xfconf-query -c xfce4-keyboard-shortcuts -r -p " /xfwm4/custom/<Primary><Alt>Up" ; xfconf-query -c xfce4-keyboard-shortcuts -r -p " /xfwm4/custom/<Primary><Alt>Down" ; xfconf-query -c xfce4-keyboard-shortcuts -r -p " /xfwm4/custom/<Primary><Alt>Left" ; xfconf-query -c xfce4-keyboard-shortcuts -r -p " /xfwm4/custom/<Primary><Alt>Right" . - Stéphane Gourichon


J'ai Ubuntu 14.04 GNOME avec LXDE. Apparemment, ce bureau a ibus-setup. Donc, pour moi, changer le paramètre ibus était la bonne solution. Peut-être que seule Unity a supprimé l'application ibus-setup.


0
2017-12-28 04:28



Oui, c'est une chose Unity. - Gunnar Hjalmarsson


le dconf-editor le changement n'était pas suffisant pour moi. J'ai la source d'entrée Mozc (japonais) installée.

Sur Ubuntu 16.04, je devais aussi:

  1. Accédez à Paramètres système -> Saisie de texte
  2. Cliquez sur Mozc pour mettre en évidence
  3. Cliquez sur l'icône clé / tournevis ci-dessous
  4. Onglet Global Config
  5. Le premier paramètre, "Trigger Input Method", était CTRL_SPACE. Je l'ai cliqué et ensuite frappé Échapper pour désactiver la reliure.

0
2017-09-08 17:18